Some deployments failing with resource is locked due to another ongoing action

Incident Report for Flightcontrol

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 20:16 EDT

Monitoring

Deployments should all be working now
Posted Aug 25, 2026 - 19:12 EDT

Identified

We're working on a fix
Posted Aug 25, 2026 - 18:18 EDT
This incident affected: Flightcontrol Deployments.